Performance degradation in EU Cluster

Incident Report for Hypatos

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 10:34 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 02, 2026 - 23:14 CET

Update

We've identified successfully the root cause and we're now implementing the fix.
Soon all documents will start to be processed as normal.
Posted Mar 02, 2026 - 15:12 CET

Identified

We are currently experiencing poor performance during document upload and processing on our EU Cluster.

Our Customer Care and Engineering teams are actively working on it.

Sorry for the inconvenience created.
Posted Mar 02, 2026 - 10:28 CET